ccna-1
15/01/2018Commands presented in the Cisco CCNA Routing and Switching 1 certification on Netacad.
basic commands
informations
Router> enable
Router> disable
Router> configure terminal
Router> exit
Router> end
Router> ctrl + z
Router> show mac address-table
Router> show ip arp
Router> show arp
Router> show cdp neighbors
Router> show protocols
Router> show version
configuration
Router> hostname SW-floor-1
Router> no hostname
Router> ip default-gateway
Router> ipv6 unicast-routing
Router> erase startup-config
Router> reload
Router> copy running-config startup-config
# configuration courante (volatile)
Router> show running-config
# configuration au démarrage (non volatile)
Router> show startup-config
layer 2 information
Router> show interfaces brief
Router> show interfaces
Router> show interface FastEthernet 0/1 brief
Router> show interface FastEthernet 0/1
layer 3 information
Router> show ip interfaces brief
Router> show ip interfaces
Router> show ipv6 interfaces brief
Router> show ipv6 interfaces
Router> show ip interface FastEthernet 0/1 brief
Router> show ip interface FastEthernet 0/1
Router> show ipv6 interface FastEthernet 0/1 brief
Router> show ipv6 interface FastEthernet 0/1
routing tables
Router> show ip route
Router> show ipv6 route
configure interfaces
# types d'interfaces
Router> line console 0
Router> line vty 0 15
Router> interface vlan 1
# IPv4
Router> interface gigabitethernet 0/0
Router> description my description
Router> ip address 192.168.1.12 255.255.255.0
Router> no shutdown
# IPv6
Router> interface gigabitethernet 0/0
Router> ipv6 address 2001:db8:acad:1::1/64
Router> ipv6 address fe80::1 link-local
Router> no shutdown
ssh access
Router> ip domain-name test.com
Router> crypto key generate rsa general-keys modulus 1024
Router> username bob secret my_pass
Router> line vty 0 15
Router> login local
Router> transport input ssh
Router> exit
security
# accès console
Router> line console 0
Router> password my_pass
Router> login
# accès privilégié
Router> enable secret my_pass
# accès distant (SSH, Telnet)
Router> line console vty 0 15
Router> password my_pass
Router> login
# message of the day
Router> service password-encryption
Router> banner motd "Accés reglementé"
# limite connexion
Router> auto secure
Router> service passwords min-length 10
Router> login block-for 120 attempts 3 within 60
# inactivité
Router> line vty 0 15
Router> exec-timeout 10
debug
Router> ping 8.8.8.8
Router> ping ipv6 8.8.8.8
Router> traceroute 8.8.8.8
Router> debug ip icmp
Router> undebug ip icmp
Router> terminal monitor